github上按照提示安装getyii不行啊,有点问题

新手提问 · wq67200976 · 于 2年前 发布 · 1331 次阅读

用git clone了getyii 然后执行初始化,初始化执行完成后 web里面多了index.php文件, 访问之后会报错,提示 require vendor 里面的autoupload.php不存在.因为下载下来的 getyii 没有vendor. 是不是我的安装方式错了,还是git clone下来之后还要执行什么命令吗 我下载其他yii2的开源也是出现同样的情况,php init 后 因为没有vendor,报错这是什么原因呢

还有个问题是如何使用github上的源代码呢, yii2 如何安装呢.还望各位大神不吝赐教

我是用source tree 克隆的

共收到 2 条回复
wq67200976#12年前 0 个赞

git hub 上的代码 是这句吧 composer global require "fxp/composer-asset-plugin:~1.1.1"git clone https://github.com/iiYii/getyii.gitcd getyiicomposer installphp init

这个应该是分开的...

  1. composer global require "fxp/composer-asset-plugin:~1.1.1"
  2. git clone https://github.com/iiYii/getyii.git
  3. cd getyii
  4. composer install
  5. php init

这样就对了吧 原谅我是新手 没看明白

echo#22年前 1 个赞

composer install 之后就会有 vendor 文件夹。

添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册