按照操作安装getyii 访问有错误

新手提问 · tudou · 于 2年前 发布 · 1578 次阅读

按照操作安装的getyii 访问有错误

PHP Compile Error – yii\base\ErrorException

Can't use method return value in write context

求大神指导

共收到 6 条回复
forecho#12年前 0 个赞

提问不够详细,至少要给出访问的链接吧?错误信息可以再多点。

tudou#22年前 0 个赞

访问的是前台首页 错误截图是 https://drp.io/i/V18cFTW1Z

forecho#32年前 0 个赞

@tudou #2楼 关于这个报错,主要是因为这个 devgroup/yii2-tag-dependency-helper 扩展,有一行代码必须要 PHP5.6 以上才支持。

解决办法有两种:

  1. 升级你的 PHP 环境到5.6以上
  2. 修改 getyii/vendor/devgroup/yii2-tag-dependency-helper/src/TagDependencyTrait.php
if (!empty($this->cacheCompositeTagFields())) {

改成

if ($this->cacheCompositeTagFields() != '') {
tudou#42年前 0 个赞

3Q 大神 还是有其他问题 然后我就下载了云盘版的

tudou#52年前 0 个赞

强烈建议写个安装程序 嘿嘿

forecho#62年前 0 个赞

@tudou #4楼 云盘版不是最新的。已经写了安装程序了,可能不太完美。

添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册